assembly error when try to create new discussion item

May 25, 2010 at 4:05 PM
Edited May 26, 2010 at 9:24 AM

successfully deployed the solution ( stsadm addsolution and deploy solution ; then activated in the site collection i wanted to use it in.

I created new enhanced discussion board list on a site and that went ok. But when I tried to create a new discussion item ( 'New/Discussion' )I got error as follows:

An error occurred during the processing of . Could not load the assembly 'LefortLudovic.SharePoint.EnhancedDiscussionBoard, Version=1.0.0.0, Culture=neutral, PublicKeyToken=d91e61839205e567'. Make sure that it is compiled before accessing the page.

 

Our server is 64bit - would that make a difference? Any ideas?

Coordinator
May 26, 2010 at 12:21 PM
Can you please check if the dll is deployed on your GAC ? c:\windows\assembly with the same version and key ? Version=1.0.0.0, PublicKeyToken=d91e61839205e567'
 
Ludovic,
 
May 26, 2010 at 12:29 PM

Hi Ludovic appreciate you getting back to me. I checked the assembly and its deployed with correct public key and version. Its showing processor architecture = x86. Our server is 64bit so wonder if this would be causing the problem if solution was compiled to 32bit ?

PS I’m not a developer so apologies  if my terminology is wrong  !!

__________________________________

Valerie Murphy

ICT Dept,

Floor 7, Cork County Council,

County Hall

email: valerie.murphy@corkcoco.ie

ext: 5718

__________________________________

From: lefortludovic [mailto:notifications@codeplex.com]
Sent: 26 May 2010 13:22
To: Valerie Murphy
Subject: Re: assembly error when try to create new discussion item [edb:213785]

From: lefortludovic

Can you please check if the dll is deployed on your GAC ? c:\windows\assembly with the same version and key ? Version=1.0.0.0, PublicKeyToken=d91e61839205e567'

Ludovic,

Read the full discussion online.

To add a post to this discussion, reply to this email (edb@discussions.codeplex.com)

To start a new discussion for this project, email edb@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Coordinator
May 26, 2010 at 12:49 PM
Indeed, that can be the reason.
 
I updated the wsp file to be compatbiel with 32 and 64 bits.
You can download the new version from codeplex.
 
Ludovic,

On Wed, May 26, 2010 at 2:29 PM, wombleval <notifications@codeplex.com> wrote:

From: wombleval

Hi Ludovic appreciate you getting back to me. I checked the assembly and its deployed with correct public key and version. Its showing processor architecture = x86. Our server is 64bit so wonder if this would be causing the problem if solution was compiled to 32bit ?

PS I’m not a developer so apologies  if my terminology is wrong  !!

__________________________________

Valerie Murphy

ICT Dept,

Floor 7, Cork County Council,

County Hall

email: valerie.murphy@corkcoco.ie

ext: 5718

__________________________________

From: lefortludovic [mailto:[email removed]]
Sent: 26 May 2010 13:22
To: Valerie Murphy
Subject: Re: assembly error when try to create new discussion item [edb:213785]

From: lefortludovic

Can you please check if the dll is deployed on your GAC ? c:\windows\assembly with the same version and key ? Version=1.0.0.0, PublicKeyToken=d91e61839205e567'

Ludovic,

Read the full discussion online.

To add a post to this discussion, reply to this email (edb@discussions.codeplex.com)

To start a new discussion for this project, email edb@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Read the full discussion online.

To add a post to this discussion, reply to this email (edb@discussions.codeplex.com)

To start a new discussion for this project, email edb@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


May 26, 2010 at 3:00 PM

Hi I downloaded updated wsp and deployed- works perfectly. Thanks Ludovic

From: lefortludovic [mailto:notifications@codeplex.com]
Sent: 26 May 2010 13:50
To: Valerie Murphy
Subject: Re: assembly error when try to create new discussion item [edb:213785]

From: lefortludovic

Indeed, that can be the reason.

I updated the wsp file to be compatbiel with 32 and 64 bits.

You can download the new version from codeplex.

Ludovic,

On Wed, May 26, 2010 at 2:29 PM, wombleval <notifications@codeplex.com> wrote:

From: wombleval

Hi Ludovic appreciate you getting back to me. I checked the assembly and its deployed with correct public key and version. Its showing processor architecture = x86. Our server is 64bit so wonder if this would be causing the problem if solution was compiled to 32bit ?

PS I’m not a developer so apologies if my terminology is wrong !!

Error! Filename not specified.

Error! Filename not specified.

__________________________________

Valerie Murphy

ICT Dept,

Floor 7, Cork County Council,

County Hall

email: valerie.murphy@corkcoco.ie

ext: 5718

__________________________________

From: lefortludovic [mailto:[email removed]]
Sent: 26 May 2010 13:22
To: Valerie Murphy
Subject: Re: assembly error when try to create new discussion item [edb:213785]

From: lefortludovic

Can you please check if the dll is deployed on your GAC ? c:\windows\assembly with the same version and key ? Version=1.0.0.0, PublicKeyToken=d91e61839205e567'

Ludovic,

Read the full discussion online.

To add a post to this discussion, reply to this email (edb@discussions.codeplex.com)

To start a new discussion for this project, email edb@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Read the full discussion online.

To add a post to this discussion, reply to this email (edb@discussions.codeplex.com)

To start a new discussion for this project, email edb@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Read the full discussion online.

To add a post to this discussion, reply to this email (edb@discussions.codeplex.com)

To start a new discussion for this project, email edb@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com