"Not safe" error

Mar 14, 2011 at 7:44 PM

I downloaded the enhanced discusison board, installed the solution, deployed it, and activiated it.  I created an Enhanced Discusison Board.  But when I went to add an item to the list, I got an error, "The type is not registered as safe."  I've never seen this before.  Can someone tell me how I resolve this issue?  Thanks.

Coordinator
Mar 14, 2011 at 8:43 PM

Hello Garry,

I suggest you to re-install the package. it seems that the assemble has not been added as Safecontrol in your applications web.config file

Sep 13, 2011 at 4:12 PM
Edited Sep 13, 2011 at 4:15 PM

I have the exact same problem as GarryM8734 - I downloaded the enhanced discussion board, add the solution, deployed it, and activated it.  I created an "Enhanced Discussion Board", but when you Add an Item to the list - receive a PARSER ERROR - The Parser Error Message is as follows: 

Parser Error Message: The base type 'LefortLudovic.SharePoint.EnhancedDiscussionBoard.NewForm' is not allowed for this page. The type is not registered as safe.

Source Error:

Line 1:  <%@ Page language="C#" MasterPageFile="~masterurl/default.master"    Inherits="LefortLudovic.SharePoint.EnhancedDiscussionBoard.NewForm, LefortLudovic.SharePoint.EnhancedDiscussionBoard, Version=1.0.0.0, Culture=neutral, PublicKeyToken=d91e61839205e567" %>
Line 2:  <%@ Register Tagprefix="SharePoint" Namespace="Microsoft.SharePoint.WebControls" Assembly="Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %> <%@ Register Tagprefix="Utilities" Namespace="Microsoft.SharePoint.Utilities" Assembly="Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %> <%@ Import Namespace="Microsoft.SharePoint" %> <%@ Register Tagprefix="WebPartPages" Namespace="Microsoft.SharePoint.WebPartPages" Assembly="Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %>
Line 3:  


Source File: /Lists/Enhanced Discussion w THREADING/NewForm.aspx    Line: 1 Source Error:

 

BTW, I have retracted and deleted the solution and re-added but no change occured.  Please provide any suggestions that you may have.  thank you.